Loading… Android P封杀老旧应用:低于这个版本都无法用了_TOM科技
正文
Qzone
微博
微信
Android P封杀老旧应用:低于这个版本都无法用了
2018-03-20 10:02 快科技   

 

iOS 10开始,苹果摒弃32位应用,这样的做法是,让设备运行效率更高,当然速度也更流畅,而现在Android P也要采取同样的做法了。

现在有开发者发现了谷歌悄悄推出的一项Android新规定,那就是Android 4.1以前的应用(包含4.1)将无法在最新版的系统中运行。

简单来说就是,谷歌在Android P中的SDK增加了一项MIN_SUPPORTED_TARGET_SDK_INT,而如果开发者在应用中没有支持这个新规定(最低SDK版本为v17,即Android 4.2后的都可以),那么低于这个版本的应用将无法安装、使用。

开发者通过虚拟机模拟Android P之后,发现Android 4.1之前的应用都虽然是可以安装的,但是打开显示的弹窗是无法使用,所以在整理应用这块,谷歌越来越像iOS看齐了。

虽说Android是开源系统,但谷歌正在对它的自由度慢慢锁紧,简单来说就是,锁定应用的隐藏API访问权限,杜绝私自访问用户设备摄像头的情况,不少开发者对此吐槽称,这样无疑让安卓的开放性受到限制,让系统变得越来越像封闭的iOS系统。

 

责任编辑: 于源亭 TW001
责任编辑: 于源亭 TW001
广告